<!DOCTYPE html>
<html lang="en"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="html not-front not-logged-in no-sidebars page-node page-node- page-node-169691 node-type-article header-with-pillar article-article">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_datacenterknowledge/images/apple-touch-icons/apple-touch_152x152.png" sizes="152x152" />
<link rel="shortcut icon" href="https://www.datacenterknowledge.com/sites/all/themes/penton_subtheme_datacenterknowledge/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_datacenterknowledge/images/apple-touch-icons/apple-touch_180x180.png" sizes="180x180" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_datacenterknowledge/images/apple-touch-icons/apple-touch_167x167.png" sizes="167x167" />
<meta name="title" content="Google Says It Will Keep Open Source Knative Project Under Its Thumb" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_datacenterknowledge/images/apple-touch-icons/apple-touch_120x120.png" sizes="120x120" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_datacenterknowledge/images/apple-touch-icons/apple-touch.png" />
<meta name="eloqua-tags" content="DCK-P-google-alphabet, DCK-S-open-source, DCK-S-devops, "/><link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_datacenterknowledge/images/apple-touch-icons/apple-touch_76x76.png" sizes="76x76" />
<meta name="description" content="In addition to Knative, which is for deploying serverless workloads, Google evidently plans to keep the Kubernetes service mesh, Istio, in-house." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.datacenterknowledge.com/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future" />
<link rel="shortlink" href="https://www.datacenterknowledge.com/node/169691" />
<meta property="og:site_name" content="Data Center Knowledge" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Google&#039;s Keeping Knative Development Under Its Thumb &#039;For the Foreseeable Future&#039;" />
<meta property="og:description" content="In addition to Knative, which is for deploying serverless workloads, Google evidently plans to keep the Kubernetes service mesh, Istio, in-house." />
<meta property="og:updated_time" content="2019-10-09T21:55:12+00:00" />
<meta property="og:image" content="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/google%20cloud%20exhibit%20frankfurt%202019%20getty.jpg" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:url" content="https://www.datacenterknowledge.com/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future" />
<meta property="twitter:title" content="Google&#039;s Keeping Knative Development Under Its Thumb &#039;For the" />
<meta property="article:published_time" content="2019-10-09T17:31:49+00:00" />
<meta property="article:modified_time" content="2019-10-09T21:55:12+00:00" />
<meta property="og:audio" content="http://" />
<meta property="og:audio:secure_url" content="https://" />
<meta property="og:video:url" content="http://" />
<meta property="og:video:secure_url" content="https://" />
<meta property="og:video:type" content="text/html" />
    <title>Google Says It Will Keep Open Source Knative Project Under Its Thumb | Data Center Knowledge</title>
    <link type="text/css" rel="stylesheet" href="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/css/css_PpiQEI-azlEmknynFVbTW6pWwXhVPT_fbABYbBL6JWQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/css/css_DHcXHPYBSjIVaCQZEG4ZlpLkvslnFlBCnQUCzlbRBio.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/css/css_4GJdl2xvrwyZP8r03oU7AnszTtBYGy_ecYVYwmYoww4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/css/css_pZxsco4eNR4BBsE0WxA8VRuq3YpiLLEug_6PnA6UUQc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/css/css_Z5xgsGQqQciuHneIDkGve-wixhB2Zoua4QMnC-XxpsY.css" media="all" />

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/css/css_d5304rVRgE97dcoJVANw-HS6Cz-71UhME-UbNuFSgx8.css" media="all" />
<![endif]-->
    <!-- HTML5 element support for IE6-8 -->
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    <script>
      var gdpr_cookie = "off";
      // Check if cookies enabled in browser.
      var cookieEnabled = navigator.cookieEnabled;
      if (typeof navigator.cookieEnabled === 'undefined' && !cookieEnabled) {
        document.cookie = 'testCookie';
        cookieEnabled = (document.cookie.indexOf('testCookie') !== -1);
      }
      if (cookieEnabled) {
        var is_cookie = document.cookie.indexOf('penton_gdpr_cookie');
        if (is_cookie == -1) {
          console.log('gdpr cookie not set');
          // Cookie is not yet set - banner just served
          gdpr_cookie = "on";
        }
      }
      console.log('gdprCookie==>' + gdpr_cookie);
    </script>
        <script>
      var isblocked = "notblocked";
      console.log('lpage==>' + isblocked);
      var pathname = window.location.pathname;
      var adu = "/3834/dcknowledge.home/article/companies/google_alphabet";
      var adblockOn = 1;
    </script>
    <script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
    <script>
      if (adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)) {
        var targ_arr = JSON.parse('[{"target":"pos","value":"728_1_a"},{"target":"combo","value":"wrap"},{"target":"ptype","value":"Article"},{"target":"nid","value":"169691"},{"target":"pterm","value":"google_alphabet"},{"target":"sterm","value":"open_source,devops"},{"target":"author","value":"christine_hall"},{"target":"reg","value":"anonymous"}]');
        googletag.cmd.push(function() {
          if (gdpr_cookie == "off") {
            googletag.pubads().setRequestNonPersonalizedAds(0);
          } else if (gdpr_cookie == "on") {
            googletag.pubads().setRequestNonPersonalizedAds(1);
          }
          var welcome_ad = googletag.defineSlot(adu, [1, 1], "div-interstitial");
          welcome_ad.addService(googletag.pubads());
          welcome_ad.setTargeting("pos", "interstitial_a");
          welcome_ad.setTargeting("gdpr_banner", gdpr_cookie);
          for (var i=0; i<targ_arr.length; i++) {
            var targ = targ_arr[i]['target'];
            var val = targ_arr[i]['value'].split(',');
            if (targ !== 'pos' && targ !== 'combo') {
              welcome_ad.setTargeting(targ, val);
            }
          }

          setTimeout(function() {
            console.log('adblockval');console.log(adblockOn);
            if(adblockOn == 1) {
              var bDiv = document.getElementById("body-wrapper");
              window.scrollTo(0, 0);
              if(bDiv.style.removeProperty) {
                bDiv.style.removeProperty('opacity');
              } else {
                bDiv.style.removeAttribute('opacity');
              }
            }
          }, 2000);

          googletag.pubads().addEventListener('slotRenderEnded', function(event) {
            adblockOn = 0;
            if(event.slot.getSlotElementId() == "div-interstitial") {
              if(event.isEmpty) {
                console.log('emptyInterstitial');
                var bDiv = document.getElementById("body-wrapper");
                window.scrollTo(0, 0);
                if(bDiv.style.removeProperty) {
                  bDiv.style.removeProperty('opacity');
                } else {
                  bDiv.style.removeAttribute('opacity');
                }
              } else {
                console.log('notemptyInterstitial');
              }

              var dfplogpatt = new RegExp('dfp_log');
              var isDebug = dfplogpatt.test(location.search);
              if(isDebug) {
                console.log('%c********DFPTag: Interstitial********', 'font-size:medium;font-style:bold');
                console.log('adunit: '+adu);
                if (gdpr_cookie == "off") {
                  console.log('nonpersonalized ads: 0');
                } else if (gdpr_cookie == "on") {
                  console.log('nonpersonalized ads: 1');
                }
                console.log('targetingpair==> pos:interstitial_a');
                console.log('targetingpair==> gdpr_banner:'+gdpr_cookie);
                for(var i=0; i<targ_arr.length; i++) {
                  var targ = targ_arr[i]['target'];
                  var val = targ_arr[i]['value'].split(',');
                  if(targ !== 'pos' && targ !== 'combo') {
                    console.log('targetingpair==> '+targ+':'+val);
                  }
                }
                console.log('adsize: [1, 1]');
                console.log('oop: false');
                console.log('%c************************************', 'font-size:medium;font-style:bold');
              }
            }
          });
          googletag.enableServices();
        });
      }
    </script>
      </head>
  <body>
        <div id="wl_flogop_div" class="hidden">https://www.datacenterknowledge.com/sites/all/themes/penton_subtheme_datacenterknowledge/images/logos/footer.png</div>
    <div id="div-interstitial">
      <script>
        if(adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)  ) {
          googletag.cmd.push(function() {
            googletag.display("div-interstitial");
          });
        }
      </script>
    </div>
        <div id="body-wrapper"  style="opacity:0;" >
            <header class="header js-header">
  <a id="skip-navigation" href="#main_content">Skip navigation</a>
  <!-- Pillar Navigation region -->
<nav class="pillar-nav">
<div id="block-penton-informa-banner-penton-informa-banner" class="block block-penton-informa-banner">

    
  <div class="content">
    <div id="iribbon-container">
    <button id="iribbon-title" title="show/hide">Informa</button>
    <div id="iribbon-detail" class="ribbon-hide">
        <div id="iribbon-left">
            <p>Data Center Knowledge is part of the Informa Tech Division of Informa PLC</p>
            <ul>
                <li class="iribbon-mainlink"><a href="http://informa.com/">Informa PLC</a></li>
                <li><a href="http://informa.com/About-Us/">About us</a></li>
                <li><a href="http://informa.com/Investors/">Investor relations</a></li>
                <li><a href="http://informa.com/Talent/">Talent</a></li>
            </ul>
        </div>
        <div id="iribbon-right">
            <p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
        </div>
    </div>
</div>  </div>
</div>
<div id="block-menu-menu-pillar-navigation" class="pillar-nav__inner l-content clearfix">
  <div class="pillar-nav__header">Discover:</div>
  <ul class="pillar-nav__items js-menumore-discover"><li class="pillar-nav__item js-menumore-item-text pillar-nav__item--content "><a href="http://www.datacenterworld.com/?_mc= itme_x_x_le_tsprtsnr_dckr_x_x-DCW20">Data Center World</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="http://www.devconnections.com/?utm_source=DCKMedia&amp;utm_medium=website&amp;utm_campaign=eyebrow-link">IT/Dev Connections</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--education "><a href="http://www.afcom.com/?utm_source=DCKMedia&amp;utm_medium=website&amp;utm_campaign=eyebrow-link">AFCOM</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--education "><a href="http://www.itprotoday.com/itdev-connections-ondemand">IT/Dev Connections OnDemand</a></li>

    <li class="pillar-nav__item pillar-more js-menumore-more-item">
      <a class="pillar-more-btn">More<i class="fa fa-caret-down"></i></a>
      <ul class="pillar-list-nested js-menumore-sub"></ul>
    </li>
  </ul></div>
</nav>
<!-- /Pillar Navigation region -->
  <!-- Header -->
  <div class="header-inner l-content">
    <!-- Hamburger menu -->
<div class="menu-toggler js-ham-menu-toggler">
  <a href="#menu" class="menu-toggler-img-wrap js-menu-toggler">
    <div class="menu-toggler-hamburger">
      <div class="hamburger-text">Menu</div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
    </div>
  </a>
  <aside class="hamburger-menu">
    <div class="hamburger-menu-inner clearfix js-toggle-menu js-sticky-ham-menu">
      <div class="hamburger-menu-container">
                  <div class="user-thumb-text">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-login" rel="nofollow">Log In</a> or <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-medium" rel="nofollow">Register</a>          </div>
                <ul class="hamburger-menu-nav"><li class="hamburger-menu-nav__item"><a href="/design" title="">Design</a></li><li class="hamburger-menu-nav__item"><a href="/manage" title="">Manage</a></li><li class="hamburger-menu-nav__item"><a href="/business" title="">Business</a></li><li class="hamburger-menu-nav__item"><a href="/cloud" title="">Cloud</a></li><li class="hamburger-menu-nav__item"><a href="/colocation" title="">Colocation</a></li><li class="hamburger-menu-nav__item"><a href="/energy" title="">Energy</a></li><li class="hamburger-menu-nav__item"><a href="/how" title="">How to</a></li><li class="hamburger-menu-nav__item"><a href="/regions" title="">Regions</a></li><li class="hamburger-menu-nav__item"><a href="/data-center-world?utm_source=DCKMedia&amp;utm_medium=website&amp;utm_campaign=hamburger-link" title="">Data Center World</a></li><li class="hamburger-menu-nav__item"><a href="/data-center-faqs" title="">Data Center FAQs</a></li><li class="hamburger-menu-nav__item"><a href="/data-center-companies-data-center-knowledge" title="">Companies</a></li><li class="hamburger-menu-nav__item"><a href="/data-center-podcast" title="">Data Center Podcast</a></li><li class="hamburger-menu-nav__item"><a href="/humor" title="">Humor</a></li></ul><ul class="hamburger-menu-sub-nav"><li class="hamburger-menu-sub-nav__item"><a href="http://www.devconnections.com/?utm_source=DCKMedia&amp;utm_medium=website&amp;utm_campaign=hamburger-link" title="">IT/Dev Connections</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://leaders.afcom.com/ll18/Public/enter.aspx" title="">AFCOM Leaders Lab</a></li><li class="hamburger-menu-sub-nav__item"><a href="/webcasts" title="">Webcasts</a></li><li class="hamburger-menu-sub-nav__item"><a href="/industry-perspectives" title="">Industry Perspectives</a></li><li class="hamburger-menu-sub-nav__item"><a href="/whitepapers" title="">Whitepapers</a></li><li class="hamburger-menu-sub-nav__item"><a href="/newsletters/signup" title="">Subscribe</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.datacenterknowledge.com/advertise-with-data-center-knowledge?utm_source=DCKMedia&amp;utm_medium=website&amp;utm_campaign=hamburger-link&amp;code=hamnav" title="">Advertise</a></li><li class="hamburger-menu-sub-nav__item"><a href="/data-center-knowledge-staff-and-contributors" title="">Our Experts</a></li><li class="hamburger-menu-sub-nav__item"><a href="/about-us" title="">About Us</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://knect365.com/privacy-policy" title="">Privacy Policy</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.penton.com/terms-of-service/" title="">Terms of Service</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://corporate.knect365.com/privacy-centre/our-cookie-policy/" title="">Cookie Policy</a></li></ul><div class="social-icons"><a href="http://facebook.com/datacenterknowledge" title="" class="social-icons__link"><i aria-label="facebook" class="social-icons__icon fa fa-facebook"></i></a><a href="http://twitter.com/datacenter" title="" class="social-icons__link"><i aria-label="twitter" class="social-icons__icon fa fa-twitter"></i></a><a href="http://www.linkedin.com/groups?gid=3317597" title="" class="social-icons__link"><i aria-label="linkedin" class="social-icons__icon fa fa-linkedin"></i></a></div>              </div>
    </div>
  </aside>
</div>
<!-- /Hamburger menu -->
    <!-- Header Logo -->
    <div class="header-logo">
                      <a href="/" class="header-logo__link"><img src="https://www.datacenterknowledge.com/sites/all/themes/penton_subtheme_datacenterknowledge/images/logos/header.png" alt="Data Center Knowledge" title="Data Center Knowledge" /></a>                  </div>
    <!-- /Header Logo -->
          <!-- Header User links -->
      <ul class="header-nav">
                  <li class="header-nav__item header-nav__item__search">
            <a href="/search" class="header-nav-link"><i class="fa fa-search"></i>Search</a>          </li>
                          <li class="header-nav__item no-mobile">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login header-nav-link" rel="nofollow">Log In</a>          </li>
          <li class="header-nav__item no-mobile last">
            <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal ctools-modal-modal-popup-medium header-nav-link sattelite-event-caller sattelite-event-caller__header-clicked" rel="nofollow">Register</a>          </li>
                <!-- Cart -->
                <!-- /Cart -->
      </ul>
      </div>

  <!-- legal communication alert -->
  <div class="js-penton-legal-comm-ajax-output-alert">
      </div>
  <!-- /legal communication alert -->
<!-- /Header -->
</header>
<!-- Page -->
<main>
  <div id="page-wraper">
    <!-- Header Adv -->
    <div class="banner-top-wrapper">
      <div id="banner-top" class="dfp-ad-hideempty hidden">
        <div data-dfp-position="top_banner"></div>
      </div>
    </div>
        <!-- Admin Tabs -->
          <section id="admin-tabs" class="l-content">
              </section>
        <!-- /Admin Tabs -->
    <!-- /Header Adv -->
    <div class="wrapper l-content">
                                <!-- Sidebar -->
        <aside id="sidebar" class="l-sidebar sidebar">
            <div class="region region-left-col">
          <div class="slide-out-sidebar-button js-expand-sidebar">
        <span class="slide-out-recent">Recent</span>
      </div>
        <div class="sidebar-wrapper sidebar-scrollable js-sticky-leftcol">
      <section id="penton_recent_content_block">
  <aside>
    <div class="r-a-header">Recent</div>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/machine-learning/intelligent-data-lake-promises-pave-way-upstream-data">
            Intelligent Data Lake Promises to Pave Way for Upstream Data            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Oct 09, 2019</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_1" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/nutanix/hpe-s-prem-nutanix-service-goes-live">
            HPE’s On-Prem Nutanix-as-a-Service Goes Live            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Oct 09, 2019</span>        </span>
          </div>
  </div>
</article>
            <div class="banner-aside-wrapper dfp-ad-hideempty">
      <div class="banner-aside js-sticky-banner dfp-ad-hideempty hidden">
        <div data-dfp-position="left_rail_rect"></div>
      </div>
    </div>
    <hr>
                    
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future">
            Google&#039;s Keeping Knative Development Under Its Thumb &#039;For the Foreseeable Future&#039;            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Oct 09, 2019</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_2" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/security/what-data-center-managers-can-do-secure-apis-new-perimeter">
            What Data Center Managers Can Do to Secure APIs, the New Perimeter            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Oct 08, 2019</span>        </span>
          </div>
  </div>
</article>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/uncategorized/top-10-data-center-stories-month-september-2019">
            Top 10 Data Center Stories of the Month: September 2019            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Oct 04, 2019</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>


<section id="penton_featured_content_block">
  <aside>
    <div class="r-a-header">Featured</div>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/edge-computing/5-key-ingredients-enterprise-edge-computing-infrastructure">
            5 Key Ingredients of an Enterprise Edge Computing Infrastructure            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 19, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/edge-computing/basics-edge-computing-and-data-center-networks">
            The Basics of Edge Computing and Data Center Networks            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 22, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/networks/disaggregated-data-center-networks-are-now-reality-what-s-next">
            Disaggregated Data Center Networks are Now a Reality. What’s Next?             <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Mar 26, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/cloud/branded-hybrid-clouds-redraw-data-center-boundaries-heres-how">
            Branded Hybrid Clouds Redraw Data Center Boundaries. Here&#039;s How            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Mar 02, 2019</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>
    </div>
  </div>
        </aside>
        <!-- /Sidebar -->
            <!-- Main Content Area -->
      <div class="page main-area l-main-area">
        <div id="main_content" class="clearfix" tabindex="-1">
          
            <div class="region region-main-col">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <section class="main-articles-container js-lazy-pager-wrapper">

    <article itemscope itemtype="http://schema.org/NewsArticle" class=" big-article article-type-article article-169691 node-type-article with-feat-img article-standalone js-lazy-pager-content"  data-nid="169691" data-url="/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future" data-title="Google&#039;s Keeping Knative Development Under Its Thumb &#039;For the Foreseeable Future&#039;" data-seo-title="Google Says It Will Keep Open Source Knative Project Under Its Thumb" data-type="article" data-terms="companies/google_(alphabet)" data-ptermhier="Companies &gt; Google (Alphabet)" data-pterm="Google (Alphabet)" data-sterm="Open Source|DevOps" data-program="" data-tax="Google (Alphabet)|Open Source|DevOps" data-buyersjourney="" data-ext="" data-author="Christine Hall" data-pub="Oct 09, 2019" data-visibility="visible" data-perm="public" data-pid="1e0dc131-8269-4240-869e-754da011706c" data-contentSponsor="" data-content="">
    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.datacenterknowledge.com/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future"/>
    <meta itemprop="datePublished" content="2019-10-09T17:14:00+00:00"/>    <meta itemprop="dateModified" content="2019-10-09T21:55:12+00:00"/>
              <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
          <meta itemprop="url" content="https://www.datacenterknowledge.com/sites/all/themes/penton_subtheme_datacenterknowledge/images/logos/header.png">
          <meta itemprop="width" content="412">
          <meta itemprop="height" content="145">
        </div>
        <meta itemprop="name" content="Data Center Knowledge">
      </div>
    
    
    <div class="big-article__top">

      
              <div class="big-article__image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
          <img class="medium js-imgpxr" data-x2src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_featured_retina/public/google%20cloud%20exhibit%20frankfurt%202019%20getty.jpg?itok=KSQLUqbA" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_featured_standard/public/google%20cloud%20exhibit%20frankfurt%202019%20getty.jpg?itok=OvkUw0eM" width="770" height="400" alt="Google Cloud exhibit at the 2019 IAA Frankfurt Auto Show in September 2019" title="Google Cloud exhibit at the 2019 IAA Frankfurt Auto Show in September 2019" />          <meta itemprop="url" content="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/google%20cloud%20exhibit%20frankfurt%202019%20getty.jpg">
          <meta itemprop="width" content="1024">
          <meta itemprop="height" content="683">

                      <span class="text-to-image">Sean Gallup/Getty Images</span>
                  </div>
                  <div class="big-article__image-caption add-info">Google Cloud exhibit at the 2019 IAA Frankfurt Auto Show in September 2019</div>
              
      <div class="big-article__head row">
        <div class="heading ">
                    <div class="breadcrumbs"><span class="parent-category"><a href="/companies">Companies</a><span>&gt;</span></span><a href="/companies/google-alphabet">Google (Alphabet)</a></div>          <h1 itemprop="headline">Google&#039;s Keeping Knative Development Under Its Thumb &#039;For the Foreseeable Future&#039;</h1>
                      <div itemprop="description">
              
  <div class="field field-name-field-penton-content-summary field-type-text-long field-label-hidden">
    In addition to Knative, which is for deploying serverless workloads, Google evidently plans to keep the Kubernetes service mesh, Istio, in-house.  </div>
            </div>
                                <p class="author-and-date" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><span itemprop="name"><a href="/author/--4" itemprop="url">Christine Hall</a></span> | <span class="date-display-single">Oct 09, 2019</span></p>
                  </div>
      </div>

      
    </div>

              <div class="share-icons">
            <a href="/penton_modal/nojs/print/169691"
         class="print ctools-use-modal ctools-modal-modal-popup-basic"
         rel="nofollow">
        <i aria-label="print" class="fa fa-print"></i>
      </a>
          <a href="/penton_modal/nojs/forward/169691/0"
         class="envelope ctools-use-modal ctools-modal-modal-popup-basic-email"
         rel="nofollow">
        <i aria-label="email" class="fa fa-envelope"></i>
      </a>
                  <a href="https://www.facebook.com/sharer.php?u=https://www.datacenterknowledge.com/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future&amp;t=Google's Keeping Knative Development Under Its Thumb 'For the Foreseeable Future'"
         class="facebook"
         target="_blank">
        <i aria-label="facebook" class="fa fa-facebook"></i>
      </a>
                <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.datacenterknowledge.com/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future&amp;title=Google's Keeping Knative Development Under Its Thumb 'For the Foreseeable Future'&amp;summary=It appears that at least one major Kubernetes-related open source project, Knative, isn't destined to join&amp;nbsp;its mother project at the Cloud Native Computing Foundation. Indeed, it's not destined to join&amp;nbsp;any foundation. According to an email sent last week to Knative developers by Donna Malayeri, a project manager at Google and a member of Knative's steering committee, Google won't be relinquishing control of the project anytime soon, if ever.&amp;source=Data Center Knowledge"
         class="linkedin"
         target="_blank">
        <i aria-label="linkedin" class="fa fa-linkedin"></i>
      </a>
                <a href="https://twitter.com/share?url=https://www.datacenterknowledge.com/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future&amp;text=Google's Keeping Knative Development Under Its Thumb 'For the Foreseeable Future'"
         class="twitter"
         target="_blank">
        <i aria-label="twitter" class="fa fa-twitter"></i>
      </a>
                <a href="https://pinterest.com/pin/create/button/?url=https://www.datacenterknowledge.com/google-alphabet/googles-keeping-knative-development-under-its-thumb-foreseeable-future&amp;description=It appears that at least one major Kubernetes-related open source project, Knative, isn't destined to join&amp;nbsp;its mother project at the Cloud Native Computing Foundation. Indeed, it's not destined to join&amp;nbsp;any foundation. According to an email sent last week to Knative developers by Donna Malayeri, a project manager at Google and a member of Knative's steering committee, Google won't be relinquishing control of the project anytime soon, if ever.&amp;media="
         class="pinterest"
         target="_blank">
        <i aria-label="pinterest" class="fa fa-pinterest"></i>
      </a>
              <a class="pinterest"
           target="_blank">
           <i aria-label="pinterest" class="fa fa-pinterest"></i>
        </a>
            </div>

              
    
    <div class="article-content-wrap">
      
      <div itemprop="articleBody" class="article-content ">
                  <div class="article-banner dfp-ad-hideempty hidden">
            <div data-dfp-position="inarticle1"></div>
          </div>
                
        <p>It appears that at least one major <a href="https://www.datacenterknowledge.com/google-alphabet/how-google-s-anthos-different-aws-and-azure-hybrid-clouds">Kubernetes-related open source project,</a> Knative, isn't destined to join&nbsp;its mother project at the Cloud Native Computing Foundation. Indeed, it's not destined to join&nbsp;any foundation. According to an email sent last week to Knative developers by Donna Malayeri, a project manager at Google and a member of Knative's steering committee, Google won't be relinquishing control of the project anytime soon, if ever.</p>

<p>Knative is a promising but not yet ready for prime time Kubernetes-based platform for&nbsp;building, deploying, and managing&nbsp;modern serverless workloads.</p>

<p>"Since the start of the Knative project, there have been questions about whether Knative would be donated to a foundation, such as CNCF," Malayeri wrote, indicating in the signature line that she was writing "on behalf of Google." "Google leadership has considered this, and has decided not to donate Knative to any foundation for the foreseeable future."</p>

<p>This came as a surprise to many Knative developers and supporters, as it's been presumed by many that Google would eventually contribute Knative&nbsp;to Kubernetes' home at the Linux Foundation's CNCF&nbsp;or to the care of another foundation offering open governance, such as the Apache Software Foundation. That's become the expected route for open source projects, as open governance is seen as an important step for building robust developer communities around projects. Many developers (as well as potential users) are suspicious of projects where a handful of vendors control direction.</p>

<p>Which seems&nbsp;to be the direction&nbsp;Knative is headed. At least for the time being, community input will be limited. The project is governed by a steering committee of seven members, four of which are Google employees, with one seat each going to Pivotal (now part of <a href="https://www.datacenterknowledge.com/networks/service-meshes-are-getting-hot-enterprise-and-vmware-listening">VMware),</a> IBM, and Red Hat. Since any action requires a majority vote, this puts Google completely in the driver's seat.</p>

<p>Google's lopsided representation on the steering committee might change, however. In the notice, Malayeri said, "Within the next few weeks, we plan to clarify how project members can attain leadership positions in Knative. As always, our goal is to ensure that Knative serves the needs of our users, the community, and everyone who benefits from using Knative." She also noted that the project remains open source, with no indication that&nbsp;that will change.</p>

<p>At this stage in the game, this might be much ado about nothing. Knative isn't yet recommended for production or expected to come out of beta until sometime in the spring.</p>

<p>Another Google-held Kubernetes-related project, Istio, wasn't mentioned in the email, but The Register reported that Google intends to hold it close to its chest too. One source closely involved in&nbsp;upstream Kubernetes development told Data Center Knowledge that Istio developers were told in a briefing that the project would remain under Google's control and not be contributed to a foundation.</p>

<p>In light of the Knative situation, this would make sense. Istio is a service mesh designed primarily to be used with Kubernetes, and it's also a necessary component for running Knative. Unlike Knative, Istio is out of beta and is already seeing production use.</p>

        
                                        </div>

      
                <div class="secondary-tags">
      TAGS:              <a href="/design/open-source" class="secondary-tag">Open Source</a>              <a href="/manage/devops" class="secondary-tag">DevOps</a>        </div>
      
              
  <div class="comments-wrapper" id="comments-169691">
    <div class="comments">
      <a href="javascript:void(0)" class="comments--show hidden">0 comments</a>    </div>
    <div class="comments-container">
      <div class="fill-comments">
        <div class="comments-header"><span class="comments--hide">Hide comments</span></div>
                  <form class="comment-form" action="/comment/reply/169691" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="user-comment-body">
  <div class="user-comment-field">
    <div class="user-photo">
      <img class="user-thumb-img" src="https://www.datacenterknowledge.com/sites/all/themes/penton_core_theme/images/account-default-image.png" alt="" />    </div>
    <div class="user-content">
      <div class="user-name">
        <a href="/" class="js-penton-user-url-profile"></a>      </div>
      <div class="user-comment">
        <div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="comment_body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label class="element-invisible" for="edit-comment-body-169691">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full ckeditor-mod form-textarea required" placeholder="Be the first to comment..." id="edit-comment-body-169691" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
<a class="ckeditor_links" style="display:none" href="javascript:void(0);" onclick="javascript:Drupal.ckeditorToggle(['edit-comment-body-169691'],'Switch to plain text editor','Switch to rich text editor');" id="switch_edit-comment-body-169691">Switch to plain text editor</a><fieldset class="filter-wrapper element-invisible form-wrapper" id="edit-comment-body-und-0-format"><div class="fieldset-wrapper"><div class="filter-help form-wrapper" id="edit-comment-body-und-0-format-help"><p><a href="/filter/tips" target="_blank">More information about text formats</a></p></div><div class="form-item form-type-select form-item-comment-body-und-0-format">
  <label for="edit-comment-body-und-0-format--2">Text format </label>
 <select class="filter-list form-select" id="edit-comment-body-und-0-format--2" name="comment_body[und][0][format]"><option value="comments" selected="selected">Comments</option><option value="plain_text">Plain text</option></select>
</div>
<div class="filter-guidelines form-wrapper" id="edit-comment-body-und-0-format-guidelines"><div class="filter-guidelines-item filter-guidelines-comments"><h3>Comments</h3><ul class="tips"><li>Allowed HTML tags: &lt;em&gt; &lt;strong&gt; &lt;blockquote&gt; &lt;br&gt; &lt;p&gt;</li></ul></div><div class="filter-guidelines-item filter-guidelines-plain_text"><h3>Plain text</h3><ul class="tips"><li>No HTML tags allowed.</li><li>Web page addresses and e-mail addresses turn into links automatically.</li><li>Lines and paragraphs break automatically.</li></ul></div></div></div></fieldset>
</div>
<a href="#" class="publish js-publish user-comment__publishbtn">Publish</a><span class='comment-error'><a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login" rel="nofollow">Log in or register to comment</a></span></div></div>      </div>
    </div>
  </div>
</div>
<input type="hidden" name="cid" value="" />
<input type="hidden" name="pid" value="" />
<input type="hidden" name="form_build_id" value="form-vYZhYPOBZQLW_tp5zOYs7JeLIA4lajVWd6r-RR9OiUc" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="captcha_sid" value="34816971" />
<input type="hidden" name="captcha_token" value="dd4e2bf75b93cf60ef08249977f67eff" />
<div class="element-invisible"><div class="form-actions form-wrapper" id="edit-actions"><button id="edit-submit-169691" name="op" value="Save" class="form-submit">Save</button>
</div></div><div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>                <div class="comments-inner-container">
                  </div>
      </div>
    </div>
  </div>
      
    </div>

    
    <div class="row related-articles-row">
              <div class="related-articles-heading">Related</div><div class="related-articles-wrapper"><a href="/google-alphabet/google-cloud-worth-double-ibm-market-cap-deutsche-bank-says" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_related_thumb_retina/public/google%20data%20center%20hamina%20inside_0.jpg?itok=26KUSCKo" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_related_thumb_standard/public/google%20data%20center%20hamina%20inside_0.jpg?itok=bg3Ff4g-" width="90" height="83" alt="A data hall inside Google&#039;s data center in Hamina, Finland" /></div><div class="small-article__inner"><div class="small-article__inner-title">Google Cloud Worth Double IBM Market Cap, Deutsche Bank Says</div><span>Oct 03, 2019</span></div></article></a><a href="/google-alphabet/google-build-cloud-data-centers-poland" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_related_thumb_retina/public/Palace%20of%20Culture%20and%20Science%20warsaw%202013%20getty.jpg?itok=gFyIboAu" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_related_thumb_standard/public/Palace%20of%20Culture%20and%20Science%20warsaw%202013%20getty.jpg?itok=qcFto25C" width="90" height="83" alt="Palace of Culture and Science in Warsaw, seen in March 2013" /></div><div class="small-article__inner"><div class="small-article__inner-title">Google to Build Cloud Data Centers in Poland</div><span>Sep 27, 2019</span></div></article></a><article class="dfp-ad-hideempty hidden n_hidden small-article" data-dfp-position="native_related"></article><a href="/google-alphabet/google-invest-33-billion-grow-european-data-centers" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_related_thumb_retina/public/google%20data%20center%20hamina%20inside_0.jpg?itok=26KUSCKo" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_related_thumb_standard/public/google%20data%20center%20hamina%20inside_0.jpg?itok=bg3Ff4g-" width="90" height="83" alt="A data hall inside Google&#039;s data center in Hamina, Finland" /></div><div class="small-article__inner"><div class="small-article__inner-title">Google to Invest $3.3 Billion to Grow European Data Centers</div><span>Sep 20, 2019</span></div></article></a><a href="/google-alphabet/google-takes-big-step-toward-powering-itself-renewables-around-clock" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_related_thumb_retina/public/Google-solar.jpg?itok=Vab5o_uP" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/styles/article_related_thumb_standard/public/Google-solar.jpg?itok=Px1FrkfQ" width="90" height="83" alt="Google-solar.jpg" /></div><div class="small-article__inner"><div class="small-article__inner-title">Google Takes Big Step Toward Powering Itself With Renewables Around the Clock</div><span>Sep 19, 2019</span></div></article></a></div>          </div>

    
    <div class="item-list"><ul class="lazy-pagination"><li class="read-more pagination-read-more next first"><a href="/machine-learning/intelligent-data-lake-promises-pave-way-upstream-data?parent=169691&infscr=1" rel="nofollow">Load More</a></li>
<li><a href="/deals/telecom-italias-23-data-centers-could-fetch-11b-planned-ipo" rel="next">Next Article</a></li>
<li class="last"><a href="/nutanix/hpe-s-prem-nutanix-service-goes-live" rel="prev">Previous Article</a></li>
</ul></div>
    
  </article>

  
</section>
  </div>
</div>
  </div>

        </div>
                <div class="banner-bottom-wrapper">
          <div id="banner-bottom" class="dfp-ad-hideempty hidden">
            <div data-dfp-position="bottom_banner"></div>
          </div>
        </div>
                <!-- /Main Content Area -->
                  <!-- Footer -->
          <!-- Check to see if we are in the store -->
  <footer class="l-footer l-footer-min ">
    <div class="l-footer-inner">
      <div class="l-footer-info">
        <div class="footer-logo-min">
                      <a href="/"><img class="footer-logo-min__site_logo" src="https://www.datacenterknowledge.com/sites/all/themes/penton_subtheme_datacenterknowledge/images/logos/footer.png" alt="Logo" /></a>                    <div class="small-12 medium-5 columns">
            <div class="footer-links">
                            <a href="https://informa.com/"><img src="/sites/all/themes/penton_core_theme/images/powered_by_informa_businessline.png" alt="Powered by Informa" /></a>            </div>
          </div>
        </div>
        <ul class="footer-min-col">
          <li class="footer-min-col__item">
      <a href="/about-us" class="footer-min-col-link">About Us</a>    </li>
          <li class="footer-min-col__item">
      <a href="/contact-us" class="footer-min-col-link">Contact Us</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://www.datacenterknowledge.com/advertise-with-data-center-knowledge?utm_source=DCKMedia&amp;utm_medium=website&amp;utm_campaign=footer&amp;code=footerlink" class="footer-min-col-link">Advertise</a>    </li>
          <li class="footer-min-col__item">
      <a href="/sitemap" class="footer-min-col-link">Sitemap</a>    </li>
            </ul>
      <ul class="footer-min-col no-margin">
        <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy#ThirdPartyAdvertisingTech" class="footer-min-col-link">Ad Choices</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://informa.com/privacy-policy/" class="footer-min-col-link">Privacy Policy</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://engage.informa.com/terms-of-service" class="footer-min-col-link">Terms of Service</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://engage.informa.com/cp/cookie-policy/" class="footer-min-col-link">Cookie Policy</a>    </li>
  </ul>
<div class="social-min-col">
  <p class="social-min-col__label">Follow us:</p>
  <div class="social-icons"><a href="http://facebook.com/datacenterknowledge" title="" class="social-icons__link"><i aria-label="facebook" class="social-icons__icon fa fa-facebook"></i></a><a href="http://twitter.com/datacenter" title="" class="social-icons__link"><i aria-label="twitter" class="social-icons__icon fa fa-twitter"></i></a><a href="http://www.linkedin.com/groups?gid=3317597" title="" class="social-icons__link"><i aria-label="linkedin" class="social-icons__icon fa fa-linkedin"></i></a></div></div>
      </div>
      <div class="l-footer-rights">
        <span class="copyrights">
          &#169; 2019 Informa USA, Inc., All Rights Reserved
        </span>
      </div>
    </div>
  </footer>
          <!-- /Footer -->
              </div>
    </div>
  </div>
</main>
<!-- /Page -->
<div id="hidden-dfp" class="dfp-ad-hideempty hidden">
  <div data-dfp-position="hidden" class="hidden-for-ads"></div>
</div>
      <script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js__PiZuK2o4XAnDCWOhogiGF01gyHzeu7QxvOyfTe-YyM.js"></script>
<script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_s3L_uC35AiN5EGYY533su-jccnLRp2aKpOnjgPLbo34.js"></script>
<script type="text/javascript" src="//assets.adobedtm.com/2ebe67d2ca0193084439038012c34f9112a85c00/satelliteLib-f42008bbb5f5518b8eb7c34ee3e92f3d69c3d378.js"></script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_aqDLL_44zBARAgd_FTblZWchUi73E-YeDLd8oMO1dX0.js"></script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_IWtAbZDjS48PA0DidE1pvGP-2jegwgb_jS2CEiOsTt0.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.CKEDITOR_BASEPATH = "/sites/all/modules/contrib/ckeditor/ckeditor/"
//--><!]]>
</script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_fy1xU2X7oZ4Yhv7hq2lsTUSulg0nEDLMdvWpknsYW7I.js"></script>
<script type="text/javascript" src="//video.limelight.com/player/embed.js"></script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_xht8E4BLA53oTxrfnKlXrB1kiW1yjdvRUnS5OTDFd_A.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexSettings = {"id":"1","property_name":"Data Center Knowledge","colors_text_primary":"#53565a","colors_text_secondary":"#ffffff","colors_bg_primary":"#ffffff","colors_bg_secondary":"#b89d18","brochure_url":"http:\/\/images.info.pentontech.com\/Web\/PentoniNET\/%7B698ef7da-6f17-40d0-ad85-a0a389771938%7D_DCK-A180572.pdf","logo_url":"https:\/\/www.datacenterknowledge.com\/sites\/all\/themes\/penton_subtheme_datacenterknowledge\/images\/logos\/header.png","subscription_url":"https:\/\/www.datacenterknowledge.com\/newsletters\/signup","gaViewID":"110625922","elqFormId":"1037","elqFormName":"INET_Promo_BounceXIntegration","eloquaInstance":"PentoniNET","elqSiteID":"1885539667","created":"1552500782"};
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexCmpgn = {"disengagement":{"step1":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD","header":"INFO ON LIQUID COOLING IN THE DATA CENTER","cta":"SEE FULL REPORT","ntb":"CONTINUE TO SITE"},"step2":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL REPORT ON WHEN AND HOW LIQUID COOLING BECOMES NECESSARY","cta":"SEE THE REPORT","ntb":""},"step3":{"preheader":"","header":"","cta":"","ntb":""},"offer":"DCKInfographic_disengagement"},"clickToCaptureDesktop":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND EXPERT INSIGHT?","cta":"YES, KEEP ME UPDATED","ntb":""},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND EXPERT INSIGHTS","cta":"CONTINUE TO SITE","ntb":""},"offer":"DCKNewsletter_desktop"},"clickToCaptureMobile":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND EXPERT INSIGHT?","cta":"YES, KEEP ME UPDATED","ntb":"NO, CONTINUE READING"},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND EXPERT INSIGHTS","cta":"CONTINUE TO SITE","ntb":""},"offer":"DCKNewsletter_mobile"},"inlinezone":{"step1":{"preheader":"DO YOU WANT ACCESS TO","header":"WHEN AND HOW LIQUID COOLING BECOMES NECESSARY?","cta":"YES, UNLOCK ACCESS","ntb":"NO, NOT RIGHT NOW"},"step2":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD","header":"INFO ON LIQUID COOLING IN THE DATA CENTER","cta":"SEE FULL REPORT","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL REPORT ON WHEN AND HOW LIQUID COOLING BECOMES NECESSARY","cta":"SEE THE REPORT","ntb":""},"offer":"DCKInfographic_Inline"}};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_VvSlYoodLAf6CoZ1-kQ6MDC-Fvy22ighqZW1xFo6HqA.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_L6OZG5KXpK9TmHNSbl24vOE0yJf48VytacfkHRBNEVc.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
Drupal.settings.penton_eloqua_api = {"fields":["nl","utm_rid"]};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_qekzEEdO6OYK9JDfHY1d86k3s6DkdpDGSrJKG4vEaz4.js"></script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_oji9_B8MxovI2pqQCxnUfSPWUa28Na17Ef-5MSc-XF8.js"></script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_Ev2a03hYfNqtDZW8vAZHfy3Nf4HzCwV9KR-zrDXM2_g.js"></script>
<script type="text/javascript">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</script>
      <script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_39wR4vuLCUZcIK_NsEhVLhl6834Dd3heLLFQ5DLVNsc.js"></script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/all/modules/contrib/ckeditor/ckeditor/ckeditor.js?py3qtk"></script>
<script type="text/javascript" src="https://www.datacenterknowledge.com/sites/datacenterknowledge.com/files/js/js_hTvEvnr-CSP0ayePYXq_lDVR4Xlir2rUBDh7jP_21fI.js"></script>
    </div>
  </body>
</html>
